Jump to content

TUTORIAL Nutzer Informationen zur DR!FT Community API


Recommended Posts

vor 14 Stunden schrieb Todesandre:

So, Windoofs 11 ist nun das Testobjekt... Nach 2h gemerkt das beim Prozessor SVM "off" stehen hatte und docker nicht starten wollte: klappt jetzt

alles fein entpackt und container läuft

Nun will ich ein rennen erstellen, geht soweit auch aber wenn ich ein rennen erstellt habe ploppt nun folgendes auf:

 

Please log in to see the images

und naja, da hänge ich jetzt halt in der Luft, vllt weiß ja jemand mehr. 

Drift APP will sich ebenfalls nicht connecten.

Bitte melde dich an um den Link zu sehen.

 vielleicht? 🙂

 

 

Bei mir hab ich das jetzt auch so kaputt bekommen 😅

Link to comment
Share on other sites

Posted (edited)

Bitte melde dich an um den Link zu sehen.

 

Bitte melde dich an um den Link zu sehen.

 Ich bekomme den Fehler jetzt auch, super seltsam. Vielleicht wurde eine Bibliothek upgedated, ich muss mir das mal anschauen.

Hab den Fehler gefunden:

https://discuss.streamlit.io/t/version-1-10-0/25987

Die haben eine neue Version von Streamlit herausgebracht, die mit der Art und Weise wie ich das gebaut habe crashed. Ich werde jetzt einfach in den Anforderungen die alte streamlit version erzwingen. Ich schreib hier, wenn ihr es neu herunter laden könnt.

Ok, Fehler ist gefixt, bitte ein mal das Projekt neu herunterladen, mit der neuen Version sollte es wieder gehen. Außerdem habe ich Maßnahmen getroffen, dass das nicht einfach so wieder passiert.

Edited by Decrayer
  • Like 1
Link to comment
Share on other sites

vor 44 Minuten schrieb Decrayer:

Ok, Fehler ist gefixt, bitte ein mal das Projekt neu herunterladen, mit der neuen Version sollte es wieder gehen. Außerdem habe ich Maßnahmen getroffen, dass das nicht einfach so wieder passiert.

Läuft danke! 
 

jetzt muss ich nur noch irgendwie die richtige IP herausfinden und dann sollte es klappen. 
welche nehmen ich am besten ohne lang zu tüfteln? 😂🙏🏼

 

Link to comment
Share on other sites

Bitte melde dich an um den Link zu sehen.

super - bei mir läuft nun auch das Webinterface soweit ohne Fehler, nachdem ich alles nochmal neu heruntergeladen habe.

Verbinden will sich die App aber nicht - Fehlermeldung kommt keine - Sync läuft nur sehr kurz - dann wieder das rote X.

Kann man das irgendwie debuggen wo es da in einen Fehler läuft?

 

Link to comment
Share on other sites

Bitte melde dich an um den Link zu sehen.

 

Bitte melde dich an um den Link zu sehen.

 und wohl auch

Bitte melde dich an um den Link zu sehen.

 ich hab jetzt den Fehler gefunden, weswegen sich die App nicht mit dem Server Synchronisiert. Man muss zwingend http:// vor die IP schreiben, das macht die App nicht automatisch🤦‍♂️😅 .

Link to comment
Share on other sites

Bitte melde dich an um den Link zu sehen.

Das kann leider an vielen Gründen liegen, angefangen von der falschen Ip, falscher Schreibweise, falscher Port, /game hinten vergessen, fehlendes http:// davor, port 8001 nicht freigegeben, nicht ins gleiche wlan eingeloggt, kein Rennen mit dieser ID angelegt...

Link to comment
Share on other sites

vor 8 Stunden schrieb Decrayer:

Bitte melde dich an um den Link zu sehen.

Das kann leider an vielen Gründen liegen, angefangen von der falschen Ip, falscher Schreibweise, falscher Port, /game hinten vergessen, fehlendes http:// davor, port 8001 nicht freigegeben, nicht ins gleiche wlan eingeloggt, kein Rennen mit dieser ID angelegt...

moin moin :-),

so ich hab es jetzt hinbekommen. Hatte die URL falsch eingetragen in der APP. Hatte 8080 als Port angegeben, damit konnte es natürlich nicht funktionieren ;-). Super jetzt läufts!  

  • Like 1
Link to comment
Share on other sites

Bei mir war es auch ein dummer Fehler, habe immer blind die 127.0.0.1 abgetippt in der App. Da muss natürlich die IP des Rechners rein. 😅

Grundsätzlich laüft es jetzt, ich kann Rennen erstellen und die Handys verbinden sich. Aber ich kann keine Vorgaben machen, die werden nicht von den Handys übernommen bzw kann ich die Uhrzeit auf dem Rechner nicht einstellen. Im Video sieht man wie du die Uhrzeit löscht und neu eigibst. Das kann ich nicht. Ich kann nur durch das dropdown Menue Viertelstündlich Uhrzeiten auswählen, die aber trotzdem nicht an die Smartphones gehen.

  • Like 1
Link to comment
Share on other sites

Posted (edited)
vor 3 Stunden schrieb der_michel:

Bei mir war es auch ein dummer Fehler, habe immer blind die 127.0.0.1 abgetippt in der App. Da muss natürlich die IP des Rechners rein. 😅

Grundsätzlich laüft es jetzt, ich kann Rennen erstellen und die Handys verbinden sich. Aber ich kann keine Vorgaben machen, die werden nicht von den Handys übernommen bzw kann ich die Uhrzeit auf dem Rechner nicht einstellen. Im Video sieht man wie du die Uhrzeit löscht und neu eigibst. Das kann ich nicht. Ich kann nur durch das dropdown Menue Viertelstündlich Uhrzeiten auswählen, die aber trotzdem nicht an die Smartphones gehen.

Bitte melde dich an um den Link zu sehen.

:

Die Zeitauswahl ist bei diesem GUI Framework blöd gelöst, aber man kann tatsächlich die genaue Zeit eingeben: In das Feld tippen und einfach Zahlen eingeben. Wenn man fertig ist, wird einem genau die angegebene Uhrzeit "vorgeschlagen", diese dann einfach noch einmal auswählen (siehe Screenshot hier drunter) und dann ist die auch gesetzt. Nicht vergessen, auf der linken Seite den jeweiligen Haken zu setzen bei Optionen die auch aktiv sein sollen ("enable...."):

Please log in to see the images

Edited by Decrayer
  • Like 1
Link to comment
Share on other sites

Wird es dann im Endeffekt eine Internetseite geben die man einfach dafür nutzen kann oder muss jeder sein eigenes ding basteln und lokal irgendwo laufen lassen? 

Ich meine dann könnte man doch schonmal die aktuelle "Version" irgendwo hosten das man es wenigstens schonmal ausprobieren kann.

  • Like 1
Link to comment
Share on other sites

Hallo, scheint wirklich eine super Sache zu werden. Nachdem auch ich sämtliche Stolpersteine lösen konnte, bin ich soweit, daß ich ein Rennen eingeben kann, die Startzeit einstellen kann, das rote x beim synchronisieren weg ist, da ich die IP des Laptops nehme. Jetzt hab ich nur noch das Problem, daß keine Daten am Pc ankommen. Ich habe in der Firewall den Port 8001 freigegeben. Ich habe Win11 Home.

Link to comment
Share on other sites

Bitte melde dich an um den Link zu sehen.

 Im Endeffekt ist eine solche Internetseite (oder mehrere) eine der Sachen, an denen jetzt wohl gebastelt wird. Wir brauchten aber erst mal die API in der APP, sonst kann man so etwas ja nicht gut testen. Die aktuelle Version ist nur ein Prototyp der z.B. auch keine Nutzerverwaltung besitzt und bei dem auf einige Sicherheitsfeatures verzichtet wurde, die man bei einer Webseite die man offen ins Internet stellt besser achten sollte. D.h. technisch könnte man die jetzt schon irgendwo hosten, ob das aber eine gute Idee wäre wage ich zu bezweifeln. Denn jeder der die IP/Adresse kennt, kann dort Rennen anlegen oder die Löschen oder schlimmstenfalls durch eine Sicherheitslücke den Server übernehmen.

Bitte melde dich an um den Link zu sehen.

 wenn der Grüne Haken erscheint, dann bekommt die App zumindest eine Antwort vom Server, eigentlich müssten dann auch Daten ankommen. Wenn du versiert genug bist, kannst du vielleicht mal mit der Software "Wireshark" deinen Netzwerkverkehr kontrollieren und schauen wo es hängen bleibt?

Link to comment
Share on other sites

vor 2 Stunden schrieb Decrayer:

Bitte melde dich an um den Link zu sehen.

:

Die Zeitauswahl ist bei diesem GUI Framework blöd gelöst, aber man kann tatsächlich die genaue Zeit eingeben: In das Feld tippen und einfach Zahlen eingeben. Wenn man fertig ist, wird einem genau die angegebene Uhrzeit "vorgeschlagen", diese dann einfach noch einmal auswählen (siehe Screenshot hier drunter) und dann ist die auch gesetzt. Nicht vergessen, auf der linken Seite den jeweiligen Haken zu setzen bei Optionen die auch aktiv sein sollen ("enable...."):

Please log in to see the images

Und gaaaanz wichtig, erst die Zeit eingeben und erst danach enable anwählen. Es scheint als ob die variable gesetzt wird im zeitpunkt des "enablen". Wenn ich erst enable und dann die zeit setzt, hab ich eine falsche Zeit.

  • Like 1
Link to comment
Share on other sites

vor 17 Minuten schrieb kinkylauda:

Und gaaaanz wichtig, erst die Zeit eingeben und erst danach enable anwählen. Es scheint als ob die variable gesetzt wird im zeitpunkt des "enablen". Wenn ich erst enable und dann die zeit setzt, hab ich eine falsche Zeit.

Hab ich gerade ausprobiert, bei mir ist es aber genau anders herum: Wenn ich erst die Zeit eingebe und dann enable, wird die falsche Zeit gesetzt (die aktuelle, nicht die eingegebene). Wenn ich erst "enable" und dann die Zeit eingebe, dann steht die richtige Zeit drin. Ist nen Bug, setz ich auf die Issue liste.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

In order to optimize our website for you and to continuously improve it, we use cookies. By continuing to use the website, you consent to the use of cookies. Further information on cookies can be found in our Privacy Policy